Touch and display issues in portrait mode

Hi Folks,

I just replaced my old touchscreen with a viewsonic touchscreen. While it technically works it is not without issue, and I want to see if someone more familiar with this can help.

First, most of the time when it boots it starts at 1080p during the boot screen, then drops to a lower resolution, this can normally be fixed by unplugging and plugging the monitor in, HDMI vs DP doesn’t seem to change much.

Second, when this happens, the UI sometimes gets stuck taking up like 1/3 of the screen instead of resizing to fit.

Last, the touchscreen has to be re-calibrated every boot, I get the message saying it couldn’t load the config and I can delete, retry, or continue (or might be “ok” can’t recall)

I figure this monitor is probably not “supported” but is there a way to dive into the Linux OS and tweak these things?

Some more digging and I think that Pathpilot is not properly detecting this monitor, it keeps resetting the orientation to landscape and I started digging around and discovered the log files and I see this in part of the pathpilot.log: touchscreen devices detected: [] ending with code 1

The screen clearly works, and I can run the calibration so something is off, and whatever method PP uses for detecting touch screens seems not to like this one.

I managed to find the place it checks where ‘valid’ monitors are and added this one to the list so while it doesn’t complain on boot it also does not apply the touchscreen correctly, it seems like it is not rotation the coordinates of the touches.

The landscape reset problem may have been caused by either by using displayport or having the keyboard plugged into the monitor, as that seems to have gone away but it still likes to boot just fine to the UI, then after ~10 seconds it changes the resolution and I can only see the gcode render pane and need to unplug and plug in the monitor to get it to reset.

It sounds like something is wonky with the communication from monitor to video graphics if it keeps going to reconfigure and switching resolutions or signal is dropping.

Linux is your main thing to be working with all this. PP doesn’t seem to have much to do with it since it hooks into the Linux touchscreen driver system.

I have gone as far as having to hack an HDMI cable and custom electronics to connect/disconnect an individual pin for a custom application totally unrelated to this one in terms of hardware hacking background…because there was nothing else available…

For this, I would try and known good HDMI cable and abandon ship if that didn’t fix it. I got my touchscreen for $100 shipped and only had to add one thing to startup to get the rotation for touch to work. You can look at my thread on what I bought and the one change I made for reference.

Viewsonic is an old company and respected but it sounds like you might have a lemon or this model isn’t fully compatible with something on your hardware and OS version…

Thanks for the reply, it looks from my digging around (just getting back to this with a set of fresh eyes) that the monitorWatch script was forcibly setting my monitor back to the default resolution of 1024x768 on startup. I changed that to the desired resolution of 1080x1920 and it boots fine and the touchscreen calibration is applied as expected on boot.

So while this means I need to track these changes every upgrade at least I pinned down what was wrong. I am curious how you were able to have yours work flawlessly out of the box as from reading through the scripts I would expect any monitor that isn’t in the list of monitors to fail on applying the touch calibration during boot, also I am a bit boggled as to how this worked for anyone with that monitorWatch script seemingly forcing the default resolution on boot.

I am probably missing something about how this all ties together somewhere but at least for the moment I seem to be up and running with the new monitor now.

Changing resolutions like we do these days is a piece of cake compared to having to calculate display clock lines back when I first used Linux in the 90’s…

I am on an older first generation PP smaller but full PC and not a mini PC, so it’s possible you have other forces at play and a different Linux distribution revision with more moving pieces.
Would have to compare those variables to figure why mine “just worked”.

Good that you got it going….