Tormach 440 Started having issues after the first few weeks

Been happy so far but woke up this morning to a 440 that started adding strange. Tried to run some parts but as soon as the Z would move down to the part it kept E Stopping or if I got past that point it would E Stop as soon as it started cutting metal.

Now its stuck in the Z as it has gotten worse as I tried…

I have determined that it is E stopping under any slight strain in the motors as the X and Y seem to move ok but the heavier Z will E stop it. Now it is stuck in the upper position.

When it E stops you can’t reset it. The only way you can get PathPilot to reset is by a lot of effort, hard rebooting PathPilot, turning machine on n off, etc… This has nothing to do with limit switches as toggling them off in path pilot and I am no where near them in the XYZ.

. After some researching I am assuming something in the electronics is fried…Driver…? I can almost smell electronics but can’t tell. It will take a lot of effort to pull this thing away from the wall and get in there so…

This sucks…

Video of it happening

and a more in depth video highlighting the problem

1 Like

Definitely a job for tormach ticket support. It’s definitely going to be electrical. Check the wires between motor and spindle drive. Because the spindle drive uses magnetic feedback it is ultra sensitive. Usually this would cause a fault instantly but yours might be just slight enough to allow it to push through for a minute. I don’t know that the fault in the wires could even be detected without special equipment. While you wait for support you could; Unplug it and check all the connections for corrosion and the wires for cracks. It’s probably an invisible metal shaving coated in coolant has been polishing off an atom or two every time it moves and slowly over the years has sliced until the wire is just a couple atoms connecting it.

This machine is brand new and about 3 weeks old… so I’m doubting it’s worn out wires or corrosion… and it’s in my small shop shared with an SLS Fuse 1 powder printer so the shop is controlled at a super low 20% humidity level.

I discovered that if I run the spindle and just “tap” lightly (flick it with my finger) on the BLDC controller (white box with digital display on it)… it replicates and kills the spindle and puts its in the reset state… so assuming the BLDC is faulty as all the wires going into it are secure. Unless the BLDC has some super sensitive motion detector in it…

[See this video](Possibly bad BLDC

@Damian_Clapper this is a good scenario for a Support ticket:How to Submit a Support Ticket
Our Support team will help you sort this out.

Yea…I put one in now we wait I guess…

As someone who runs other machines and this Tormach 440 literally being brand new and less than a few weeks into running it… this is not a good representation of this machine.

Hoping this is just a “lucky lemon” and not a glimpse into a long trend.

If you are looking to investigate further today without direction from tech support:

I could be mistaken but a stopped/stalled spindle doesn’t e-stop the machine…been a while since I’ve done that and paid attention to what I had to do to get out of it…I recall stalled->stopped spindle doesn’t restart but the steppers need to be re-referenced because they kept moving but once the spindle is free to rotate again, one can go back to machining after referencing and resetting WCS.

I recall the upper spindle access switch stops the spindle but does so by cutting power to the BLDC entirely, so you would lose the red spindle display if that was faulty/intermittent.

Maybe obvious and the first thing you did but have you checked in there (upper spindle area) for belt tension/rubbing for your rotational noise?

Have you checked the e stop circuitry against the schematics and metered them when it goes into e stop (I see that message on your display in the videos) to confirm or deny if that is the culprit (bad wire/switch)?

The tapping on the BLDC and it stopping is weird. We thought I had a bad one (was not stopping like yours) but it turned out to be something else.

Troubleshooting that for me involved metering the low voltage leads going into the spindle from the machine controls to see if you have enable signal and voltage to drive a given RPM when it goes to 0 RPMS when you tap it…

Appreciate the information but all this “troubleshooting” I’m hearing being done… is making me question this purchase…

It’s not just the spindle stopping it’s stopping randomly from all sorts of things within minutes of resetting and referencing the XYZ.

For instance… I just tried running it again. Got the spindle to warm up routine. Then I got it at 6500 RPM and brought it down manually to attempt a manual pass at some aluminum. As soon as I got it into position and was ready to cut, I turned on the coolant (fogbuster) and it instantly killed it. Just from touching the coolant button.

After that I had to reset and reference. Got it back to 6500 rpm. Started to bring the Z down n it died while moving the Z.

Had to reset and reference.

It’s totally random but won’t do anything past a minute or so of movement.

Yes just breathing on the spindle control unit kills it.

Not too impressed with all the troubleshooting experts I’m hearing from out there…especially on a three week old machine… lots of people it seems have had to become experts at keeping this machine running… which is unfortunate

I can understand your frustration with it being brand new. I wouldn’t want to dig into any of this if I were in your shoes and I would also expect it to “just work”.

I got my 440 secondhand and without going into details, it is not “stock”, so that adds another level of complexity to my troubleshooting. I knew what I was getting myself into in terms of having to go into the weeds and having to dig into manuals and schematics to figure things out but I’m used to doing that and prefer to have a self-support option…

Tech support was responsive to my inquiry upon opening a support ticket (during their stated business hours) and hopefully will get you sorted out quickly and provide pinpointed guidance of what exactly to test as opposed to the suggestions made here…

I’m sure Tormach support has already gotten back to you this morning, but on your video you try and jog the Z axis BEFORE all axis where homed - Pathpilot doesn’t allow this - that’s why your got that error … Not saying you dont have issues and maybe you could not home any axis. hope you get it figured out

Also - the standard post processor for Tormach in fusion 360 doe not support in-process probing
if you want to do that you’ll have to use Xoomspeed version from David Loomes, it’s included the Pathpilot directory - you may need to get the most up to date version from Xoomspeed tho - it’s free

No, in that one stance I may not have re referenced the XYZ as I been experiencing this shut off at least a hundred times in an eight hour period. When it happens (every 2-3 minutes of trying) all references are dropped.

In fact I found if I open the spindle door when the trigger is released it will drop all references which is strange…

Again, I have run this machine with great success for nearly two weeks… this is not “user error”.

And no… unfortunately Tormach support has not responded as of yet

And on the Xoomspeed…I will say that this all happened immediately upon using xoomspeed as the post processor and sending it to the 440… not sure that is a coincidence but also note… Fusion 360 does now allow in process probing it just gave error messages in pathpilot so Tormach needs to update and that was confirmed by David Loomes of xoomspeed yesterday as he was surprised to see Fusion had added it recently and stated that Tormach needs to know there are errors in using it

So after an hour of great tech support… we discovered the relay is the issue.

By tapping any where on the machine with just slight finger pressure… moving the Z, spindle…turning on coolant… the slightest of vibration would soft e stop the machine due to this relay box. Then you couldn’t bring it out of e stop unless you tapped on the relay box a few times.

We jumpered 303 and 304 bypassing that relay and it works.


Wow. Thanks for posting an update. That’s a strange scenario. Good work to you and support on figuring that one out

1 Like

Thats great that your issue got figured out - sounds very frustrating.

Can you expand on what you are refereeing to as far as probing?
Fusion always did allow in-process probing (only to set the WCS)- but the post-pro has to handle it - the Fusion 360 post for Tormach did not accommodate this - that’s why David built one that did.

Fusion does have advanced probing, but you have to own the machining extension

So what has changed that you discussed with David? I’m not seeing anything different in Fusion

1 Like

The Tormach post processor in Fusion can now send out probing. He had looked at it this week and said he was surprised to see it and they must have just done it. However you get name errrors when sending it to PathPilot so he told me Tormach would need to update PathPilot to accommodate this new update… not sure past that but you’d have to ask him.

@Damian_Clapper, @Lockheed CAM driven probing has been one of my side projects, and it does require a Pathpilot update. I’d hoped to have it completed a month or two ago but other projects have jumped the line. Fingers crossed I’ll be able to get to it in the next month or so.

A sneak peak of the write-up on the probing routines I’ve written, but there are many changes needed to this documentation since the last revision so nothing should be taken as final from this document:
_21154787-CAM Driven Probing-090424-180752.pdf (250.6 KB)


1 Like

Thanks for posting the photo of the relay causing the problem.