Mx1100 atc m19

Nearly every day I have to set the M19 spindle encoder alignment when I power up the machine. It’s done this from the beginning ( 2 years) but I’ve put off finding a fix so I don’t have to do it every day. After I set the M19 spindle encoder, then the spindle lines up with the ATC tray with no issues. for the rest of the day.

Lately it’s been harder to successfully execute the M19 spindle alignment. It takes 2 or 3 tries sometimes.

Any thoughts? Is there something I can adjust or clean?

@James_Avey Welcome to the Tormach Forums!

Have you have any encoder errors occur when you command your spindle? This would certainly be a good candidate for a technical support case. Jira Service Management

No errors except spindle is obviously not lined up for the first tool change of the day. After I set the M19 then it works fine. I’ve learned the hard way to look at the spindle and check to see if it’s aligned for a tool change when I start up the machine.

@James_Avey when this happens next, immediately capture a log data file for us: and open up a ticket and send this in to us!

@SamBollen in the following command line M19 R0 Q10 can you help me break that down? I believe M19 is the command for aligning the spindle I think the R0 is the number of degrees to turn it and I’m stuck on Q10 close collet? TIA


M19 is indeed spindle orient. R is degree to orient to. Q would be the amount of seconds to complete the orient

So interestingly enough if I run M19 R0 Q10 it never gets to Q10 it just stays with the brake engaged. I can run Q10 after it sits there and the brake stops and the drawbar retracts. I do have a ticket open but not making any progress. It must be very busy in support right now as I’m not really getting replies with any substance.

@James_Avey did you solve this spindle alignment problem? I’m having the same issue.

@Scott_Dube I will look into your case, and try to get it pushed forward.

1 Like

Thanks Sam! I appreciate it.

That is because the M19 orient completed and is just wrong in it’s position. It won’t time out unless it does not orient. It does, its just not accurate.

It’s why I requested the video (Thank you for that) . Take a look at your case. I responded to the ticket.


First, after talking with support I figured out I wasn’t exiting path pilot properly. Now I E stop the machine then touch exit on the path pilot screen and then I power down the controller. Before I would just E stop and the power down the controller and machine

Second, I also re-installed the PathPilot software on my controller. Everything is great now. Don’t know which change made the difference. Good luck!


Nice chatting with you by phone today. I’m glad we were able to get through the issues on the power drawbar and re-image successfully to solve the M19 issue.


1 Like

Thanks @James_Avey we ended up reimaging PathPilot and it solved the issue!

1 Like