Delayed power drawbar activation at startup on pcnc1100 series 3

When I first use the power drawbar after several hour or day non use. I have to hold down on the collet release button or the foot release for 15 to 30 seconds before the pnuematic valve actuates to make the power drawbar work. I have replaced the servo valve a couple times. But it will still not actuate immediately at first startup reliably.

I bought this mill used a three years ago, it was manufactured in 2017 . At the time I bought it had corrosion in the servo valve for the power drawbar that prevented it from actuating. Since replacing the valve, the air filter and air oiler, I haven’t had corrosion in the pnuematics of the mill.

Welcome to the forums, Kirk!

I just happened to notice that I took a case with you already. I would love to dig into this issue with you a bit more. Look for a response on your ticket!

I tried to create a video clip, but today the drawbar wouldn’t fire at all, so the trouble shooting items on the Tormach website will now be more effective. I have the rapid turn installed for the next few days for a paying customer, so it will be a few days before I can probe with the DVM.

After working with Tormach tech support, we trouble shot the issue down the power drawbar controller card. What was happening during the 15 to 30 seconds, was the voltage to the valve slowly climbed from under 10VDC to 12VDC, it was like a capacitor charging. Once the voltage hit 12VDC the solenoid had enough actuation force to make the valve switch. The 12VDC power supply in the cabinet was good as its voltage held steady at 12VDC. The controller was on back order so it took two months to get.

I installed it in last week (now that sucks as I had to climb on top of the ways and crouch down inside the enclosure and fiddle around with screws that are really a PITA to get at).

Good news was in addition to fixing the power drawbar actuation, my tool changer now works reliably like when I first got the machine.

Best Regards,

1 Like