Accessing network

I can;t get PP on my machne to access my network.

If you mean that you want path pilot to browse to a network location so you can download a g-code file from a NAS, I asked and Tormach won’t allow it for security reasons.

Have you tried this process?

I guess we are all replying and assuming this question isn’t about very basic networking, like just getting an IP address?

The video or this PDF should work and is officially supported

This alternative is an unofficial option but has been documented several times/places but requires some basic Linux administration familiarity.

An NFS export on a NAS (TrueNAS, in my case) and the appropriate mount entry on the PP controller works without changing much on a PP controller (adding packages or other major changes).


  1. Complete backup of your PP controller beforehand and have a method to restore it
  2. Backup the mount configuration file before editing
  3. Edit the configuration file carefully

NFS doesn’t like disconnections:

  1. make sure you have more than adequate WiFi coverage
  2. upgrade to a newer WiFi USB adapter if you have a really old one (2018 “full PC” controller)

I ran into the case where PP can “slow down” and act as if it’s “frozen” if your WiFi drops out. I had to revert to not using NFS until I upgraded my main WAP and put the old one the same floor as the mill (basement) to have more consistent signal.